No. of Recommendations: 0
I get notified that I need to update ImageMagick by their regular update tool. But when I try to run the tool to update the program, it fails.

So I manually downloaded the update and tried to do it manually. No good. It claims to be dependent on two libraries, but I have them. Not only that, but they are part of the same .rpm, so they must be compatible.

# rpm -Uvh ImageMagick-6.7.2.7-2.el6.x86_64.rpm
error: Failed dependencies:
libMagickCore.so.2()(64bit) is needed by (installed) libxine1-1.1.19-5.el6.x86_64
libMagickWand.so.2()(64bit) is needed by (installed) libxine1-1.1.19-5.el6.x86_64

# ls -l /usr/lib64/libMagick*
lrwxrwxrwx. 1 root root 22 Feb 11 2014 /usr/lib64/libMagickCore.so.2 -> libMagickCore.so.2.0.0
-rwxr-xr-x. 1 root root 2229096 Jan 30 2014 /usr/lib64/libMagickCore.so.2.0.0
lrwxrwxrwx. 1 root root 22 Feb 11 2014 /usr/lib64/libMagickWand.so.2 -> libMagickWand.so.2.0.0
-rwxr-xr-x. 1 root root 1097720 Jan 30 2014 /usr/lib64/libMagickWand.so.2.0.0

# rpm -qf /usr/lib64/libMagickCore.so.2
ImageMagick-6.5.4.7-7.el6_5.x86_64
DellT7600:root[/opt/downloaded/RedHatImageMagick]# rpm -qf /usr/lib64/libMagickWand.so.2
ImageMagick-6.5.4.7-7.el6_5.x86_64
Print the post  

Announcements

What was Your Dumbest Investment?
Share it with us -- and learn from others' stories of flubs.
When Life Gives You Lemons
We all have had hardships and made poor decisions. The important thing is how we respond and grow. Read the story of a Fool who started from nothing, and looks to gain everything.
Community Home
Speak Your Mind, Start Your Blog, Rate Your Stocks

Community Team Fools - who are those TMF's?
Contact Us
Contact Customer Service and other Fool departments here.
Work for Fools?
Winner of the Washingtonian great places to work, and Glassdoor #1 Company to Work For 2015! Have access to all of TMF's online and email products for FREE, and be paid for your contributions to TMF! Click the link and start your Fool career.
Advertisement