UnThreaded | Threaded | Whole Thread (7) | Ignore Thread Prev | Next
Author: jiml8 Big gold star, 5000 posts Old School Fool Add to my Favorite Fools Ignore this person (you won't see their posts anymore) Number: of 6630  
Subject: Who knows this... Date: 4/15/2001 5:24 PM
Post New | Post Reply | Reply Later | Create Poll . Report this Post | Recommend it!
Recommendations: 0
I nearly have my entire configuration runnning. Samba is talking to my NT boxes with no problems, but we are not yet connecting with the Win95 box. I know there are some issues there...I'll get it. The 95 box can connect with this Linux box using TCP/IP, so users on the box can get to the internet.

I have squid running. I have Socks5 running. I have IPChains running. All well and good.

What I don't have running is diald.

The message in the syslog is from chat. It says "Can't get terminal parameters. Inappropriate ioctl for device."

I have compiled diald for user authentication using TCP_Wrappers and PAM. The diald.conf file specifies device /dev/ttyS14. I have tried variants using the other known names for this device; /dev/ttyLT0, /dev/ltmodem, and of course, /dev/ppp0.

I recompiled without PAM...no change in the message. I have also tried without providing the full path, just the device name. All give the identical error message. But the modem works; I am using it now, via a manual dialup.

The modem is a winmodem, but it is the Lucent chipset and when I compiled and linked the Lucent driver set it worked with no issues.

I don't see why there would be an ioctl issue.
Anyone have any ideas?
Post New | Post Reply | Reply Later | Create Poll . Report this Post | Recommend it!
Print the post  
UnThreaded | Threaded | Whole Thread (7) | Ignore Thread Prev | Next

Announcements

Post of the Day:
Value Hounds

Mylan Transitioning from Generics
What was Your Dumbest Investment?
Share it with us -- and learn from others' stories of flubs.
When Life Gives You Lemons
We all have had hardships and made poor decisions. The important thing is how we respond and grow. Read the story of a Fool who started from nothing, and looks to gain everything.
Community Home
Speak Your Mind, Start Your Blog, Rate Your Stocks

Community Team Fools - who are those TMF's?
Contact Us
Contact Customer Service and other Fool departments here.
Work for Fools?
Winner of the Washingtonian great places to work, and "#1 Media Company to Work For" (BusinessInsider 2011)! Have access to all of TMF's online and email products for FREE, and be paid for your contributions to TMF! Click the link and start your Fool career.
Advertisement