No. of Recommendations: 1
fwiw, in DiskUtility I ran FirstAid on the disk and it didn't return any errors. I don't know what first aid checks for for, I just know that it didn't find anything. There was not a functioning OS on the disk when I ran it.

Disk Utility does filesystem scans, but it doesn't do bad block (surface) scans. For that, you need an application that does surface scans, like Techtool Pro. I think Diskwarrior used to do such scans, but I don't think it does so any more. I'm pretty sure Apple Hardware Test doesn't do a surface scan, either, but I think you probably verified that the other hardware is okay by running it.

BTW, depending on how large your drive is, it can take a day or more to do a surface scan. OTOH, if there are lots of bad blocks, it may catch a few almost immediately and allow you to stop the test.

I'm a little confused that you mentioned downloading Mojave via Disk Utility. Do you mean you tried downloading it by booting into the Recovery Partition?

In any case, based on what you've written, I think we can safely state the following:

-- Apple Hardware Test shows no errors, so it's not hardware like RAM, ports, etc. AHT tests the hard drive, but only the sensor and fan (see https://discussions.apple.com/thread/4897338), so you need Disk Utility or some other disk diagnostic to test the drive integrity.
-- Disk Utility tests the drive as okay, so it's not an error at the filesystem level. However, Disk Utility does not do a surface scan (i.e. check for bad blocks).
-- An attempt at a clean install (onto the erased disk) fails, so it's not an installed-software problem, e.g. Microsoft Office isn't your problem.
-- Recovering a very old Time Capsule backup apparently succeeds, but it's still slow. Since the backup contained years-old software and OS, your problem is unlikely to be software creep.

The only diagnostic that remains that I can think of is a surface scan (or bad block scan). If you don't want to try out Techtool Pro or some other application that does such scans, you can try installing the command line utility called badblocks using MacPorts, if you have that installed. I've used it on Ubuntu to do surface scans.

If someone else can think of a hardware issue that AHT doesn't cover, I'm open to suggestions, but as someone else confirmed in another message, the problem you describe has all the characteristics of a hard drive failure. IMO, the most likely HD failure in your case is bad blocks or bad sectors. (I suppose corrupted HD firmware could do it and not be detectable, too.)

-awlabrador
Print the post  

Announcements

What was Your Dumbest Investment?
Share it with us -- and learn from others' stories of flubs.
When Life Gives You Lemons
We all have had hardships and made poor decisions. The important thing is how we respond and grow. Read the story of a Fool who started from nothing, and looks to gain everything.
Contact Us
Contact Customer Service and other Fool departments here.
Work for Fools?
Winner of the Washingtonian great places to work, and Glassdoor #1 Company to Work For 2015! Have access to all of TMF's online and email products for FREE, and be paid for your contributions to TMF! Click the link and start your Fool career.