No. of Recommendations: 2
Sorry, I saw that you had said it worked in firewire target mode, but I had missed the "moving firewire symbol" part.

If I try to boot it up all the way to Mac OS X it goes into white screen mode and just sits.

You've probably tried it, but if not you should try booting from an install DVD. If that works, try running Disk Utility while booted like that. That will let it more thoroughly check the internal HD that you normally boot from.

My 20" iMac did a similar thing, back when I had it with us on a trip to my parents, a few days before taxes were due...which I was still working on. After backing up anything important (luckily I brought a lot of things with me since I was planning on fixing both my parents tower and a friend's 13" MBP), I reinstalled the OS via DVD, and then installed all the updates.

It might not be your same problem, but it was similar enough. If you feel like putting a little more time into that machine, I'd suggest booting off the DVD, running disk utility, and then if everything is backed up that you want, try reinstalling.

Aaron
Print the post  

Announcements

What was Your Dumbest Investment?
Share it with us -- and learn from others' stories of flubs.
When Life Gives You Lemons
We all have had hardships and made poor decisions. The important thing is how we respond and grow. Read the story of a Fool who started from nothing, and looks to gain everything.
Contact Us
Contact Customer Service and other Fool departments here.
Work for Fools?
Winner of the Washingtonian great places to work, and Glassdoor #1 Company to Work For 2015! Have access to all of TMF's online and email products for FREE, and be paid for your contributions to TMF! Click the link and start your Fool career.